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Welcome to the SparkFun Inventor’s Guide

The SparkFun Inventor's Guide is your map for navigating
the waters of beginning embedded electronics. This
booklet contains all the information you will need to
explore the 14 circuits of the SparkFun Inventor's Kit for
Arduino. At the center of this manual is one core
philosophy - that anyone can (and should) play around
with electronics. When you're done with this guide, you'll
have the know-how to start creating your own projects
and experiments. Now enough talking - let's get inventing!

sparkfun.com
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What is an Arduino?

The Arduino Revolution

Arduino is an open-source physical computing platform
designed to make experimenting with electronics more
fun and intuitive. Arduino has its own unique, simplified
programming language, a vast support network, and
thousands of potential uses, making it the perfect platform
A R D U I NO for both beginner and advanced DIY enthusiasts.

arduino.cc

A Computer for the Physical World

The friendly blue board in your hand (or on your
desk) is the Arduino. In some ways you could
think of Arduino as the child of traditional desktop
and laptop computers. At its roots, the Arduino is
essentially a small portable computer. It is capable
of taking inputs (such as the push of a button or a
reading from a light sensor) and interpreting that
information to control various outputs (like a
blinking LED light or an electric motor).

That's where the term "physical computing" is \ /

born - an Arduino is capable of taking the world of
electronics and relating it to the physical world in — —
a real and tangible way. Trust us - this will all make

more sense soon. / ARDUINO \

// Arduino UNO smp R3

The Arduino Uno is one of several development
boards based on the ATmega328. We like it mainly
because of its extensive support network and its
versatility. It has 14 digital input/output pins (6 of
which can be PWM outputs), 6 analog inputs, a 16
MHz crystal oscillator, a USB connection, a power
jack, an ICSP header, and a reset button. Don’t
worry, you'll learn about all these later.
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Download the Arduino IDE (integrated Development Environment)

Access the Internet

In order to get your Arduino up and running, you'll need to

download some software first from www.arduino.cc (it's
‘ free!). This software, known as the Arduino IDE, will allow
v you to program the Arduino to do exactly what you want.

It’s like a word processor for writing programs. With an
internet-capable computer, open up your favorite browser
and type in the following URL into the address bar:

m arduino.cc/en/Main/Software | < case sensitive >

4 N

Click on the “ + ” sign next to your
Download X & 2

appropriate computer operating system.
+ Windows
+ MacOS X
4+ Linux: 32 bit, 64 bit
+ source

\ )

4 N\

ARDUINO C]

Download the Arduino Software

oy dvnining e it o o,y et b pcdarms

0 Choose the appropriate Operating System installation package for your computer.



// Connect your Arduino Uno to your Gomputer

Use the USB cable provided in the SIK kit to connect the Arduino
to one of your computer’s USB inputs.

1| o~
Ifjis

// Install Drivers

Depending on your computer’s operating system, you will need to follow specific
instructions. Please consult the URLs below for specific instructions on how to
install the drivers onto your Arduino Uno.

*You will need to scroll to the section labeled “Install the drivers”.

Windows Installation Process

Go to the web address below to access the instructions for
installations on a Windows-based computer.

bttp://arduino.cc/en/Guide/Windows

Macintosh 0S X Installation Process

( / Macs do not require you to install drivers. Enter the following URL if
you have questions. Otherwise proceed to next page.
\/-\/
bttp://arduino.cc/en/Guide/MacOSX
Linux: 32 bit / 64 bit, Installation Process
Go to the web address below to access the instructions for
installations on a Linux-based computer.

bttp://www.arduino.cc/playground/Learning/Linux



// Open the Arduino IDE:

Open the Arduino IDE software on your computer. Poke around and get to know
the interface. We aren’t going to code right away, this is just an introduction. The
step is to set your IDE to identify your Arduino Uno.




GU' (Graphical User Interface)

1 Verify: Compiles and approves your code. It will catch errors in syntax (like missing semi-colons or parenthesis).  See Diagram Below

ou should see the lights on your board bli See Diagram Below

. This button will let you up an existing sketc! See Diagram Below
5  Save: This saves the currently active sketch.
6 Serial Monitor: This will open a window that displays any serial information your Arduino is transmitting. It is very useful for debugging.
7 ' Sketch Name: This shows the name of the sketch you are currently working on.
8 Code Area: This is the area where you compose the code for your sketch.

9 Message Area: This is where the IDE tells you if there were any errors in your code.

1/ The three most important commands for this guide are seen below:

Open

Verify

Upload




// Select your Serial Device

// Select your board: Arduino Uno

Auto Format

Archive Sketch

Fix Encoding & Reload
Serial Monitor

Serial Port

Programmer
Burn Bootloader

, > Wi

4 Arduino Duemilanove w/ ATmega328]

Arduino Diecimila or Duemilanove w/ ATmega168
Arduino Nano w/ ATmega328

Arduino Nano w/ ATmega168

Arduino Mega 2560 or Mega ADK

Arduino Mega (ATmega1280)

Arduino Mini

Arduino Mini w/ATmega168

Arduino Ethernet

Arduino Fio

Arduino BT w/ ATmega328

Arduino BT w/ATmega168

LilyPad Arduino w/ ATmega328

LilyPad Arduino w/ ATmega168

Arduino Pro or Pro Mini (5V, 16 MHz) w/ATmega328
Arduino Pro or Pro Mini (5V, 16 MHz) w/ATmega168
Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ATmega328
Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ATmega168
Arduino NG or older w/ ATmega168

Arduino NG or older w/ ATmega8

Auto Format

Archive Sketch

Fix Encoding & Reload
Serial Monitor

Board »
Serial Port 3
2 ~ seri o i " com 12
Select the serial device of the Arduino board from Programmer
the Tools | Serial Port menu. This is likely to be Burn Bootloader
com3 or higher (COM1 and COM2 are usually
reserved for hardware serial ports). To find out,
you can disconnect your Arduino board and
re-open the menu; the entry that disappears
should be the Arduino board. Reconnect the board
and select that serial port.
I Auto Format
Archive Sketch
~ Fix Encoding & Reload
L Serial Monitor
- Board »
Serial Port » /dev/tty.usbmodem262471
/dev/cu.usbmodem262471
Select the serial device of the Arduino board from Programmer > | /dev/tty Bluetooth-Modem

the Tools > Serial Port menu. On the Mac, this
should be something with /dev/tty.usbmodem
(for the Uno or Mega 2560) or
/dev/tty.usbserial (for older boards) in it.

Burn Bootloader /dev/cu.Bluetooth-Modem

/dev/tty.FireFly-7256-SPP
/dev/cu.FireFly-7256-SPP
/dev/tty.tiPhone-WirelessiAP-1
/dev/cu.tiPhone-WirelessiAP-1
/dev/tty.Bluetooth-PDA-Sync
/dev/cu.Bluetooth-PDA-Sync

A http://www.arduino.cc/playground/Learning/Linux



Download Arduino Code (For use with the circuits in this guide)

e e e\
— —— = =)\
[E— \

Type in the following URL to download the code:

sparkfun.com/sikcode

|
° - l ‘ (© start —» © Programs —» (O arduino —» ([ examples

|

Unzip the file “SIK Guide Code”.
It should be located in your
browser’s “Downloads” folder.
Right click the zipped folder and
choose “unzip”.

Copy the “SIK Guide Code” folder into Arduino’s
folder named “examples”.

. @3 Contents
Z o '
-/ (& Resources
\ 4 Find “Arduino” in your applications ¢
folder. Right click(ctrl + click) on & Java
“Arduino”. Select “Show Package e
Unzip the file “SIK Guide Code”.  Contents”. \:
It should be loacted in your 3 examples
browser’s “Downloads” folder. Arduino
Right click the zipped fold d Open
e lf 1.e ,7,lp pecloldetan Copy the “SIK Guide Code” folder
choose “unzip”.

into Arduino’s folder named
“examples”.

Move to Trash

// Copy “SIK Guide Code” into “Examples” library in Arduino folder

a http://www.arduino.cc/playground/Learning/Linux
‘;A/




Getting Started with Circuits

What is an Electrical Circuit?

A circuit is basically an electronics loop with a starting
point and an ending point - with any number of compo-
nents in between. Circuits can include resistors, diodes,
inductors, sensors of all sizes and shapes, motors, and any
other handful of hundreds of thousands of components.

Circuits are usually divided into three categories - analog
circuits, digital circuits, or mixed-signal circuits. In this
guide, you will explore all three sets of circuits.

The World Runs on Circuits:

Everywhere you look, you'll find circuits. The
cell phone in your pocket, the computer that
controls your car's emissions system, your
video game console - all these things are chock
full of circuits. In this guide, you'll experiment
with some simple circuits and learn the gist of
the world of embedded electronics.
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// Simple and Complex Circuits
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In this guide, you will be primarily exploring
simple circuits - but that doesn't mean you
can't do amazing things with simple tools!
When you've finished the SIK, your
knowledge of circuits will enable you to
explore amazing projects and unleash the
power of you imagination.
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Inventory of Parts

Jumper Wire
Various Colors

/

I

LED (5mm) (J——+

(Light Emitting Diode)

x10

x1

3309 Resistor

&

* ACTUAL SIZE

10KQ Resistor

&

* ACTUAL SIZE

Potentiometer

¢

Diode
(1N4148)

* ACTUAL SIZE

Photo Resistor

Piezo Element

Temp. Sensor
(TMP36)

x1

Transistor
(P2N2222AG)

DC Motor
x1

Push Button




Flex Sensor Arduino Board
UNO - SMD Version
x1
Soft Potentiometer
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Arduino Uno

Power In (Barrel Jack) - Can be used with either a 9V or 12V wall-wart or battery.

Power In (USB Port) - Provides power and communicates with your board when plugged into your computer via USB.

LED (RX: Receiving) - This shows when the Arduino is receiving data (such as when being programmed).

LED (TX: Transm ) - This shows when your Arduino is transmitting data (such as when running a program).

LED (Pin roubleshooting) - This LED is incorporated into your sketch to show if your program is running properly.

Pins (ARef, Ground, Digital, Rx, Tx) - These various pins can be used for inputs, outputs, power, and ground. // See Diagram Below

LED (indicates Arduino is ON) - This is a simple power indicator LED.

Reset Button - This is a way to manually reset your Arduino, which makes your code restart.

ICSP Pins (Uploading Code without Bootloader) - This is for "In-Circuit Serial Programming,” used if you want to bypass the boot loader.

Pins (Analog In, Power In, Ground, Power Out, Reset) - These various pins can be used for inputs, outputs, power, and ground. // See Diagram Below

// Pins Diagram

I

The header pins are one of the most important parts for putting our
0 example circuits together. Take a moment and locate the inp p
ports of your Arduino Uno.
SCL B
SDA
AREF ARef
— GND Ground
RFU 13 Digital
IOREF .
12 Digital
Reset RESET
~11 Digital
Power Out 3.3v
~10 Digital
Power Out 5V
~9 Digital
Ground GND e G
o 8 Digital
Ground GND g
@ Power In VIN T 7 Digital
g ~6 Digital
Analog A0 ¢ = Digital
Analog Al - 4 Digital
> 2 1
Analog A2 § s -3 Digital
Analog A3 6 E 2 Digital
Analog A4 ; ™1 X - Out
Analog A5 RX <0 RX-In

@)

O

o~ =PWM/Analog out compatible (i.e.~3)
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Breadboard

1 Vertical Connection (+ Power and - Ground = See Diagram Bel

2 Horizontal Connection (a-e &f-j See Diagram Below]
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How It Works

UPLOAD

3

2 WRITE

1 ASSEMBLE

+ Connect the USB cable.

+ Peel sticker off back of

+ Make sure the text on the Arduino and

Breadboard are facing up so you can read them.

+ Screw the Arduino board down and into place.

Breadboard and stick into place.

5V Current Your Arduino runs on five volts. This is the power that will be supplied from your

computer via USB and will be the driving force behind any components you use in your circuits. By

you are supplying it with just the right voltage it

needs to thrive! 5V can’t hurt you, so don’t be afraid to touch anything in your citcuit.

plugging your Arduino board into your computer,




Pin 13 Arduino Bllnklng a LED

LEDs (light-emitting diodes) are small, powerful lights
LED that are used in many different applications. To start off
SZ (Light Emitting Diode) the SIK, we will work on blinking an LED. That's right
- it's as simple as turning a light on and off. It might
not seem like much, but establishing this important
baseline will give you a solid foundation as we work
toward more complex experiments.

Resistor (3300hm)

(Orange-Orange-Brown)

GND + Each Circuit begins with a brief description
— (ground) () of the what you are putting together and

the expected result.

+ This is a schematic of your circuit. ]

LED 330Q Wire
/ Resistor
x1 x1 x3<+ This section lists the parts you

will need to complete the circuit.

+ This is an illustration of how the
completed circuit should look. It is not
necessary to use the black holder for the
Arduino and Breadboard, but we
recommend it for the first time inventor!

+ Components like Resistors need
to have their legs bent into 90°
angles in order to correctly fit the
breadboard sockets.
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Open Up the Arduino IDE software on your computer. Coding in the Arduino
language will control your circuit. Open the code for Circuit 1 by accessing the “SIK
Guide Code” you downloaded and placed into your “Example” folder earlier.

. MG edic skewch Tools Help

New
Open...
Sketchbook »
1.Basics »
Close 2.Digital 4
Save 3.Analog | 4
Save As... 4.Communication >
Upload 5.Control >
Upload Using Progammer 6.Sensors >
7.Displays | 4
Page Setup 8.5trings >
Print ArduinolSP
Circuit #2
EEPROM Circuit #3
Ethernet Circuit #4
Firmata Circuit #5
Liquid Crystal Circuit #6
sD Circuit #7
Servo Circuit #8
SoftwareSerial Circuit #9
SPI Circuit #10
Stepper Circuit #11
Wire Circuit #12
Circuit #13
Circuit #14
// Circuit #1

n an LED o

for one

(A

ize the digd

al pin as an outpuk.
mected on most Ardvino boards

FPin has an LED
) pintlode(13, OUTFUT);

void leop() {
digitalWrite(13, HIGH);
de ;

GiqitalTrite(13, LOWY;
delay(1000);




N

This compiles your code. The IDE changes it from text into instructions the computer

can understand.

v Verify

This sends the instructions via the USB cable to the computer chip on the Arduino board.

‘The Arduino will then begin running your code automatically.

Upload

>

it with correct code after verified and uploaded.

circui

// The result of a completed




+ This is where you will find the
Arduino code for each circuit.

J , w| Open Arduino IDE // File > Examples > SIK Guide > Circuit # 1
Code to Note: + Remember to Verify and >° °

Upload your code.

+ Begin to understand how the
Arduino code works. See below.

Before you can use one of the Arduino's pins, you need to tell the
pinMode(13, OUTPUT); Arduino whether it is an INPUT or OUTPUT. We use a built-in
"function" called pinMode() to do this.

‘When you're using a pin as an OUTPUT, you can command it to be

digitalWrite(13, HIGH); )
HIGH (output 5 Volts), or LOW (output 0 Volts).

What you Should See. + See if your circuit is complete

and working in this section.

You should see your LED blink on and off. If
itisn't, make sure you have assembled the

circuit correctly and verified and uploaded the
code to your board or see the troubleshooting
tips below.

il
I ||| l + Here you will find examples of the circuit

you just completed in the real world.
Many of the theories in these circuits are
used in things you use everyday!

+ This is a section dedicated to the most
common mistakes made while assembling
the circuit.

Troubleshooting: Real World Application:

LED Not Lighting Up? Almost all modern flat screen televisions and monitors
LEDs will only work in one direction. Tty taking it out and have LED indicator lights to show they are on or off.
tVViSﬁng it 180 degrefs (no need to worry, installing it backwards does

no permanent harm).

Program Not Uploading

This happens sometimes, the most likely cause is a confused
serial port, you can change this in tools>serial port>

Still No Success?
A broken circuit is no fun, send us an e-mail and we will get
back to you as soon as we can: techsupport@sparkfun.com




Potentiometer

+5 Volts In this circuit you'll work with a potentiometer.
A potentiometer is also known as a variable resistor.
m Arduino ; Arduino When it’s connected with 5 volts across its two outer
Pin AG pins, the middle pin outputs a voltage between 0 and
5, depending on the position of the knob on the
potentiometer. In this circuit, you'll learn how to use
\/ LED § D

a potentiometer to control the brightness of an LED.

resistor (3300hm)
(Orange-Orange-Brown)

p— GND
(ground) (-

Potentiometer LED 330Q Wire
/ Resistor
x1 x1 x1 x6




Circuit 2: Potentiometer
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| , | Open Arduino IDE // File > Examples > SIK Guide > Circuit # 2

Code to Note:

00

A "variable" is a number you've given a name to. You must
. . introduce, or "declare" variables before you use them; here we're
int sensorValue; . ) L
declaring a variable called sensorValue, of type "int" (integer). Don't
forget that variable names are case-sensitive!

sensorValue = analogRead(sensorPin); :>

We use the analogRead() function to read the value on an
analog pin. analogRead() takes one parameter, the analog
pin you want to use ("sensorPin"), and returns a number
("sensorValue") between 0 (0 Volts) and 1023 (5 Volts).

The Arduino is very very fast, capable of running thousands of lines
, of code each second. To slow it down so that we can see what it's
delay(sensorValue); ) . . )
doing, we'll often insert delays into the code. Delay() counts in
milliseconds; there are 1000 ms in one second.

What you Should See:

You should see the LED blink faster
or slower in accordance with your
potentiometer. Ifit isn't working,
make sure you have assembled the
circuit correctly and verified and
uploaded the code to your board or
see the troubleshooting tips below.

Troubleshooting:

Sporadically Working

'This is most likely due to a slightly dodgy connection
with the potentiometer's pins. This can usually be
conquered by holding the potentiometer down.

Not Working

Make sure you haven't accidentally connected the
potentiometer's wiper to digital pin 2 rather than analog
pin 2. (the row of pins beneath the power pins).

Still Backward
You can try operating the circuit upside down.
Sometimes this helps.

Real World Application:

MP3 players’ volume control is an example of a
potentiometer in action.




I Pin 11 | I Pin10| I Pin9 |

resistor

(3300hm)
(Orange-Orange-Brown)

Q

AV

—L__ GND
—  (ground) (-)
LED 330Q Wire
Resistor

x1 x3 x6

RGB LED

You know what’s even more fun than a blinking
LED? A colored one. RGB, or red-green-blue, LEDs
have three different color-emitting diodes that can be
combined to create all sorts of colors. In this circuit,
you’ll learn how to use an RGB LED to create unique
color combinations. Depending on how bright each
diode is, nearly any color is possible!




Circuit 3: RGB LED
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| , | Open Arduino IDE // File > Examples > SIK Guide > Circuit # 3
Code to Note: v o °

A forQ loop is used to step a number across a range, and

for (x = 0; X < 768; x++) repeatedly runs code within the brackets {}. Here the variable "x"
i starts a 0, ends at 767, and increases by one each time ("x++").

if (x <= 255) "If / else" statements are used to make choices in your programs. The

{} :> statement within the parenthesis () is evaluated; if it's true, the code within
else the first brackets {} will run. If it's not true, the code within the second

{} brackets {} will run.

The Arduino is very very fast, capable of running thousands of lines
of code each second. To slow it down so that we can see what it's

delay(sensorValue); ) . . )
doing, we'll often insert delays into the code. Delay() counts in
milliseconds; there are 1000 ms in one second.

What you Should See:

You should see your LED turn on,
but this time in new, crazy colors! If it
isn't, make sure you have assembled
the circuit correctly and verified and
uploaded the code to your board or
see the troubleshooting tips below.

7 !
5 N
T W

) “(,\

Troubleshooting: Real World Application:

LED Remains Dark or Shows Incorrect Color Many electronics such as

With the four pins of the LED so close together, it’s videogame consoles use RGB

sometimes easy to misplace one. Double check each LED:s to have the versatility

pin is where it should be. to show different colors in
the same area. Often times

Seeing Red the diffent colors represent

'The red diode within the RGB LED may be a bit brighter different states of working

than the other two. To make your colors more balanced, condition.

use a higher ohm resistor. Or adjust in code.

analogWrite(RED_PIN, redIntensity);

o

analogWrite(RED_PIN, redIntensity/3);




CIRCUIT #4

| Pin2 || Pin3 || Pin 4 || Pin5 |

LED

Lo Emting Diode

resistor
(3300hm)
©range-Crange Brown)

— GND
| Pin 6 || Pin7 || Pin8 || Pin9 |
LED
o o
resistor
(3300hm)
oo e o
—L— aND
= (ground) ()
LED 330Q Wire

Resistor
x8 x8 x10

Multiple LEDs

So you have gotten one LED to blink on and off —
fantastic! Now it's time to up the stakes a little bit — by
connecting EIGHT LEDS AT ONCE. We'll also give
our Arduino a little test by creating various lighting
sequences. This circuit is a great setup to start practicing
writing your own programs and getting a feel for the
way Arduino works.

Along with controlling the LEDs, you'll learn about a
couple programming tricks that keep your code neat
and tidy:

for() loops - used when you want to run a piece of
code several times

arrays| ] - used to make managing variables easier by
grouping them together
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Circuit 4: Multiple LEDs
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| , | Open Arduino IDE // File > Examples > SIK Guide > Circuit # 4

Code to Note:

int ledPins[] = {2,3,4,5,6,7,8,9}; |:>

digitalWrite(ledPins[0], HIGH); |:>

00

When you have to manage a lot of variables, an
"array" is a handy way to group them together. Here
we're creating an array of integers, called ledPins,
with eight elements.

You refer to the elements in an array by their position. The first
element is at position 0, the second is at position 1, etc. You refer to
an element using "ledPins[x]" where X is the position. Here we're

making digital pin 2 HIGH, since the array element at position 0 is "2".

Computers like to do the same things each time they run. But
. sometimes you want to do things randomly, such as simulating the
index = random(8); :> o youw: a & R Y, su ! .l g
roll of a dice. The random() function is a great way to do this. See
http://arduino.cc/en/Reference/Random for more information.

What you Should See:

"This is similar to circuit number one, but
instead of one LED, you should sce all the
LED:s blink. If they aren't, make sure you
have assembled the circuit correctly and
verified and uploaded the code to your board
or see the troubleshooting tips below.

Troubleshooting:

Some LED:s Fail to Light

It is easy to insert an LED backwards. Check the LEDs
that aren't working and ensure they the right way
around.

Operating out of sequence

With eight wires it's easy to cross a couple. Double check
that the first LED is plugged into pin 2 and each pin
there after.

Starting Afresh

Its easy to accidentally misplace a wire without noticing.
Pulling everything out and starting with a fresh slate is
often easier than trying to track down the problem.

Real World Application:

Scrolling marquee displays are generally used to spread
short segments of important information. They are built
out of many LEDs.

@00 8 888 000 8 00 .
@O0 8 8 8 8 8 8 808

e e 008 eoCO808 e
e 8008 . e 0808 .
e e 08 ® eee 00 e 0 8 (8




Push Buttons

I Pin 2 | I Pin 3 | Up until now, we’ve focused solely on outputs. Now
+5 Volts we're going to go to the other end of spectrum and
m M play around with inputs. In this circuit, we’ll be
- looking at one of the most common and simple
resistor

inputs — a push button. The way a push button works
| | with Arduino is that when the button is pushed, the
\/ LED I I voltage goes LOW. The Arduino reads this and reacts
H HI accordingly. In this circuit, you will also use a pull-up
| | resistor, which helps clean up the voltage and prevents

resistor (3300hm) false readings from the button.
(Orange-Orange-Brown)

—— GND
(ground) ()

Push Button LED 10KQ 330Q Wire
/ Resistor Resistor
x2 x1 x2 x1 x7




Circuit 5: Push Buttons
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| , | Open Arduino IDE // File > Examples > SIK Guide > Circuit # 5
Code to Note: v o °

The digital pins can be used as inputs as well as
pinMode(button2Pin, INPUT); |:> outputs. Before you do either, you need to tell the
Arduino which direction you're going.

To read a digital input, you use the digitalReadQ
button1State = digitalRead(button1Pin); function. It will return HIGH if there's 5V present at
the pin, or LOW if there's OV present at the pin.

Because we've connected the button to GND, it will read LOW
if (button1State == LOW) [:> when it's being pressed. Here we're using the "equivalence"
operator ("==") to see if the button is being pressed.

What You Should See:

You should see the LED turn on
and off as you press the button. If
it isn't working, make sure you
have assembled the circuit correctly
and verified and uploaded the code
to your board or see the
troubleshooting tips below.

Troubleshooting: Real World Application:

Light Not Turning On 'The buttons we used here are similar to the buttons in
'The pushbutton is square, and because of this it is easy to most videogame controllers.

put it in the wrong way. Give it a 90 degree twist and see

if it starts working.

Light Not Fading

A bit of a silly mistake we constantly made, when you
switch from simple on off to fading, remember to move
the LED wire from pin 13 to pin 9.

Underwhelmed

No worries, these circuits are all super stripped down to
make playing with the components easy, but once you
throw them together the sky is the limit.




CIRCUIT #6

Photo Resistor

Pin 9 +5 Volts So you've already played with a potentiometer, which
varies resistance based on the twisting of a knob. In
this circuit, you'll be using a photo resistor, which

\v4 LED :::?;(t)or changes resistance based on how much light the
sensor receives. Since the Arduino can’t directly
interpret resistance (rather it reads voltage), we use a
voltage divider to use our photo resistor. This voltage
% resistor (ssonm) divider will output a high voltage when it is getting a
(Orange-Orange-Brown) lot of light and a low voltage when it is not.

resistor (10k ohm)
(Brown-Black-Orange)

— GND
(ground) (-)

LED 330Q
Resistor

10KQ
Resistor
x1




Circuit 6 : Photo Resistor
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| , | Open Arduino IDE // File > Examples > SIK Guide > Circuit # 6
Code to Note: v o °

|:> ‘When we read an analog signal using analogRead(), it will
be a number from 0 to 1023. But when we want to drive a
lightLevel = map(lightLevel, 0, 1023, 0, 255);  PWM pin using analogWrite(), it wants a number from 0 to
255. We can "squeeze" the larger range into the smaller
range using the map() function.

|:> Because map() could still return numbers outside the "to"
range, we'll also use a function called constrain() that will

lightLevel = constrain(lightLevel, 0, 255); "clip" numbers into a range. If the number is outside the
range, it will make it the largest or smallest number. If it is

within the range, it will stay the same.

What You Should See:

You should see the LED grow brighter
or dimmer in accordance with how
much light your photoresistor is
reading. Ifit isn't working, make sure
you have assembled the circuit
correctly and verified and uploaded
the code to your board or see the
troubleshooting tips below.

Troubleshooting: Real World Application:

LED Remains Dark A street lamp uses a light sensor to detect when to turn
'This is a mistake we continue to make time and time the lights on at night.

again, if only they could make an LED that worked both

ways. Pull it up and give it a twist.

It Isn't Responding to Changes in Light -
Given that the spacing of the wires on the photo-resistor //
is not standard, it is easy to misplace it. Double check it’s / ‘ \

in the right place.

Still Not Quite Working

You may be in a room which is either too bright or dark.
Try turning the lights on or off to see if this helps. Or if
you have a flashlight near by give that a try.



+5 Volts

TMP36
(precision
temperature
sensor)

GND
(ground) ()

Temperature Sensor

A temperature sensor is exactly what it sounds like —a
sensor used to measure ambient temperature. This
particular sensor has three pins — a positive, a ground,
and a signal. For every centigrade degree it reads, it
outputs 10 millivolts. In this circuit, you'll learn how to
integrate the temperature sensor with your Arduino,
and use the Arduino IDE’s debug window to display
the temperature.

When you're building the circuit be careful
not to mix up the temperature sensor and the

transistor, they’re almost identical.

i — >4




Circuit 7: Temperature Sensor
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| , | Open Arduino IDE // File > Examples > SIK Guide > Circuit # 7

Serial.begin(9600); |:>

Serial.print(degreesC); |:>

Serial.println(degreesF);

What You Should See:

00

Before using the serial monitor, you must call Serial.begin() to
initialize it. 9600 is the "baud rate", or communications speed.
When two devices are communicating with each other, both
must be set to the same speed.

The Serial.printQ) command is very smart. It can print out almost
anything you can throw at it, including variables of all types,
quoted text (AKA "strings"), etc.

See bttp.//arduino.cc/en/Serial/Print for more info.

Serial.printQ will print everything on the same line. Serial.printlnQ
will move to the next line. By using both of these commands
together, you can create easy-to-read printouts of text and data.

/

You should see be able to read the MO O jdevjtty.usbmodem24131

tcmper ature your tcmpcr ature

sensor is detecting on the serial

monitor in the Arduino IDE. If it voltage: 0.73 deg C: 22.75 deg F: 72.96

isn't working, make sure you have voltage: 0.73 deg C: 22.75 deg F: 72.96

assembled the circuit correctly and
verified and uploaded the code to

your board or see the troubleshoot- voltage: 0.73 deg C: 22.75 deg F: 72.96

ing tips below. voltage: 0.73 deg C: 22.75 deg F: 72.96

# Autoscroll No line ending [+ (9600 baud

voltage: 0.73 deg C: 22.75 deg F: 72.96

\\ AN -

Troubleshooting:

Nothing Seems to Happen

Real World Application:

Building climate control systems use a temperature sensor

'This program has no outward indication it is working. To to monitor and maintain their settings.
see the results you must open the Arduino IDE's serial

monitor (instructions on previous page).

Gibberish is Displayed

'This happens because the serial monitor is receiving data at
a different speed than expected. To fix this, click the
pull-down box that reads "*** baud" and change it to

"9600 baud".

Temperature Value is Unchanging

Try pinching the sensor with your fingers to heat it up or
pressing a bag of ice against it to cool it down.
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CIRCUIT #8

A Single Servo

E Servos are ideal for embedded electronics applications
because they do one thing very well that spinning motors
cannot — they can move to a position accurately. By

Mini Servo varying the pulse of voltage a servo receives, you can
signal move a servo to a specific position. For example, a pulse

(white) of 1.5 milliseconds will move the servo 90 degrees. In this

":) = sy circuit, you'll learn how to use PWM (pulse width
gnd (red) modulation) to control and rotate a servo.
(black)
(grou(:v;l(l?) e @ +5 volts

(5v)




Circuit 8: A Single Servo
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| , | Open Arduino IDE // File > Examples > SIK Guide > Circuit # 8

00

#include is a special "preprocessor" command that inserts a library

#include <Servo.h> |:>

(or any other file) into your sketch. You can type this command
yourself, or choose an installed library from the "sketch / import
library" menu.

The servo library adds new commands that let you control a servo.

Servo servol;

servol.attach(9);

|:> To prepare the Arduino to control a servo, you must first create a
Servo "object" for each servo (here we've named it "servol"), and

then "attach" it to a digital pin (here we're using pin 9).

Servos don't spin all the way around, but they can be commanded to move to

servol.write(180); |:>

a specific position. We use the servo library's write() command to move a
servo to a specified number of degrees(0 to 180). Remember that the servo

requires time to move, so give it a short delay( if necessary.

What You Should See:

You should see your servo motor move to
various locations at several speeds. If the
motor doesn't move, check your
connections and make sure you have
verified and uploaded the code, or see the
troubleshooting tips below.

Troubleshooting:

Servo Not Twisting
Even with colored wires it is still shockingly easy to pluga
servo in backward. This might be the case.

Still Not Working

A mistake we made a time or two was simply forgetting
to connect the power (red and brown wires) to +5 volts
and ground.

Fits and Starts

If the servo begins moving then twitches, and there's a
flashing light on your Arduino board, the power supply
you are using is not quite up to the challenge. Using a
wall adapter instead of USB should solve this problem.

Real World Application:

Robotic arms you might see in an assembly line or sci-fi
movie probably have servos in them.




CIRCUIT #9

- Ea Flex Sensor

resistor
(10K ohm)
(Brown-Black-Orange)

In this circuit, we will use a flex sensor to measure,
well, flex! A flex sensor uses carbon on a strip of
plastic to act like a variable resistor, but instead of
changing the resistance by turning a knob, you

flex change it by flexing (bending) the component. We
sensor use a "voltage divider" again to detect this change in
resistance. The sensor bends in one direction and the
more it bends, the higher the resistance gets; it has a
range from about 10K ohm to 35K ohm. In this

2%
ﬂ - m circuit we will use the amount of bend of the flex
sensor to control the position of a servo.
U Mini Servo
GND —L—

(ground) (-)

10KQ Wire
Y Resistor
' 1 x1 x11

+5 volts

Py Flex Sensor Servo

-




Circuit 9: Flex Sensor
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| , | Open Arduino IDE // File > Examples > SIK Guide > Circuit # 9
Code to Note: v o °

I:> Because the flex sensor / resistor combination won't
give us a full zero to five-volt range, we're using the
servoposition = map(flexposition, 600, 900, 0, 180);  map( function as a handy way to reduce that range.
Here we've told it to only expect values from 600 to
900, rather than 0 to 1023.

Serial.print("sensor: "); Because map() could still return numbers outside the "to"
range, we'll also use a function called constrain() that will
"clip" numbers into a range. If the number is outside the

Serial. print(flexposition); :

JOX P "] " cetvo: M. . . .
Serial.print(" servo: "); range, it will make it the largest or smallest number. If it is

Serial. println(servoposition); within the range, it will stay the same.

What You Should See:

You should see the servo motor move
in accordance with how much you
are flexing the flex sensor. If it isn't
working, make sure you have
assembled the circuit correctly and
verified and uploaded the code to
your board or see the troubleshooting
tips below.

Troubleshooting: Real World Application:

Servo Not Twisting Controller accessories for videogame consoles like

Even with colored wires it is still shockingly easy to plug a Nintendo’s “Power Glove” use flex-sensing technology. It

servo in backwards. This might be the case. was the first video game controller attempting to mimic
hand movement on a screen in real time.

Servo Not Moving as Expected

'The sensor is only designed to work in one direction. Try

flexing it the other way (where the striped side faces

out on a convex CUIVC).

Servo Doesn’t Move very Far
You need to modify the range of values in the call to the
map() function.




CIRCUIT #10

+5 volts
resistor (10K ohm) Ve 2
Brown-Black-Orange) 2
=
— =
T« vieer
=
=
=
=
i =
) SE—
2 AAAA
£ WW ved
2 AMA N
£ YWY green V1 I
IS AMA N -
E YWY biue GND
t \ ) (ground) (-)
resistor (3300hm)
(Orange-Orange-Brown)
Soft Potentiometer  Wire 330Q
Resistor

Soft Potentiometer

In this circuit, we are going to use yet another kind of
variable resistor — this time, a soft potentiometer (or
soft pot). This is a thin and flexible strip that can
detect where pressure is being applied. By pressing
down on various parts of the strip, you can vary the
resistance from 100 to 10K ohms. You can use this
ability to track movement on the soft pot, or simply
as a button. In this circuit, we’ll get the soft pot up
and running to control an RGB LED.

10KQ
Resistor



Circuit 10: Soft Potentiometer
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J , | Open Arduino IDE // File > Examples > SIK Guide > Circuit # 10
Code to Note: v o °

I:> These big, scary functions take a
redValue = constrain(map(RGBposition, 0, 341, 255, 0), 0, 255) single Value (RGBposition) and
+ constrain(map(RGBposition, 682, 1023, 0, 255), 0, 255); calculate the three RGB values
necessary to create a rainbow of
color. The functions create three
greenValue = constrain(map(RGBposition, 0, 341, 0, 255), 0, 255) "peaks" for the red, green, and blue
- constrain(map(RGBposition, 341, 682, 0,255), 0, 255); values, which overlap to mix and
create new colors. Even if you're
not 100% clear how it works, you
blueValue = constrain(map(RGBposition, 341, 682, 0, 255), 0, 255) can copy and paste this (or any)
- constrain(map(RGBposition, 682, 1023, 0, 255), 0, 255); function into your own code and

use it yourself.

What You Should See:

You should see the RGB LED change
colors in accordance with how you
interact with the soft potentiometer.
If it isn't working, make sure you
have assembled the circuit correctly
and verified and uploaded the code to
your board, or see the troubleshoot-
ing tips below.

Troubleshooting: Real World Application:

LED Remains Dark or Shows Incorrect Color ‘The knobs found on many objects, like a radio for
With the four pins of the LED so close together, it’s instance, are using similar concepts to the one you just
sometimes easy to misplace one. Try double checking each completed for this circuit.

pin is where it should be.

Bizarre Results

‘The most likely cause of this is if you're pressing the
potentiometer in more than one position. This is normal
and can actually be used to create some neat results.

888




Buzzer

Pin 9

In this circuit, we'll again bridge the gap between the
digital world and the analog world. We'll be using a
buzzer that makes a small "click” when you apply
voltage to it (try it!). By itself that isn't terribly

. exciting, but if you turn the voltage on and off
Piezo hundreds of times a second, the buzzer will produce a
—— Element tone. And if you string a bunch of tones together,
you've got music! This circuit and sketch will play a
classic tune. We'll never let you down!

il

——— GND

— (ground) (-)

Piezo Element Wire

+ If the buzzer doesn't easily fit
into the holes on the breadboard,
try rotating it slightly.




Circuit 11: Piezo Elements
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| , | Open Arduino IDE // File > Examples > SIK Guide > Circuit # 11

Code to Note:

char notes[] = "cdfda ag cdfdg gf ";

=

char names[] = {'c','d','e','f,'g",'a','b','C'};

tone(pin, frequency, duration);

What You Should See:

You should see - well, nothing!
But you should be able to hear
you piezo element playing
"Twinkle, Twinkle Little Star" (or
possibly, "The ABCs"). If it isn't
working, make sure you have
assembled the circuit correctly and
verified and uploaded the code to
your board or see the
troubleshooting tips below.

Troubleshooting:

No Sound

Given the size and shape of the piezo element it is easy to
miss the right holes on the breadboard. Try double
checking its placement.

Can't Think While the Melody is Playing
Just pull up the piezo element whilst you think, upload
your program then plug it back in.

Tired of Twinkle Twinkle Little Star

'The code is written so you can easily add your own songs.

00

Up until now we've been working solely with numerical
data, but the Arduino can also work with text. Characters
(single, printable, letters, numbers and other symbols) have
their own type, called "char". When you have an array of
characters, it can be defined between double-quotes (also
called a "string"), OR as a list of single-quoted characters.

One of Arduino's many useful built-in commands is the
tone() function. This function drives an output pin at a
certain frequency, making it perfect for driving buzzers and
speakers. If you give it a duration (in milliseconds), it will
play the tone then stop. If you don't give it a duration, it
will keep playing the tone forever (but you can stop it with

another function, noTone() ).

Real World Application:

Many modern megaphones have settings that use a loud
amplified buzzer. They are usually very loud and quite
good at getting people’s attention.

l,'



resistor (3300hm)
(Orange-Orange-Brown)
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emitter
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motor

+5 volts
(5v)

Transistor Diode
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/

multimeter

GND
(ground) (-)

transistor
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Spinning a Motor

Remember before when you played around with a servo
motor? Now we are going to tackle spinning a motor.
This requires the use of a transistor, which can switch a
larger amount of current than the Arduino can. When
using a transistor, you just need to make sure its
maximum specs are high enough for your use. The
transistor we are using for this circuit is rated at 40V max
and 200 milliamps max — perfect for our toy motor!

When you're building the circuit be careful
not to mix up the transistor and the

temperature sensor, they’re almost identical.

330Q
Resistor
x1
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Circuit 12 : Spinning a Motor
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Code to Note:

=

while (Serial.available( > 0)

speed = Serial.parseInt(Q;

=

What You Should See:

The DC Motor should spin if you have
assembled the circuit’s components correctly,
and also verified/uploaded the correct code. If
your circuit is not working check the
troubleshooting section below.

Troubleshooting:

Motor Not Spinning

If you sourced your own transistor, double check with
the data sheet that the pinout is compatible with a
P2N2222AG (many are reversed).

Still No Luck

If you sourced your own motor, double check that it will
work with 5 volts and that it does not draw too much
power.

Still Not Working

Sometimes the Arduino board will disconnect from the
computer. Try un-plugging and then re-plugging it into
your USB port.

00

The Arduino's serial port can be used to receive as well as
send data. Because data could arrive at any time, the Arduino
stores, or "buffers" data coming into the port until you're
ready to use it. The Serial.availableQ) command returns the
number of characters that the port has received, but haven't

been used by your sketch yet. Zero means no data has arrived.

If the port has data waiting for you, there are a number of
ways for you to use it. Since we're typing numbers into the
port, we can use the handy Serial.parseInt() command to
extract, or "parse" integer numbers from the characters it's
received. If you type "1" "0" "0" to the port, this function

will return the number 100.

Real World Application:

Radio Controlled(RC) cars use Direct Current(DC)
motors to turn the wheels for propulsion.




Relays

resistor (z3oohm)
(Orange-Orange-Brown)

In this circuit, we are going to use some of the lessons we
base ) learned in circuit 12 to control a relay. A relay is basically
transistor K . . N
“ 4~ P2N2222AG an electrically controlled mechanical switch. Inside that
_‘ emitter harmless looking plastic box is an electromagnet that,
resistor (3soohm) . . . .
(orange-0rango-Brown) when it gets a jolt of energy, causes a switch to trip. In
this circuit, you'll learn how to control a relay like a pro

— giving your Arduino even more powerful abilities!

+5volts

collector

woo

diode
(flyback)

1100

ON
—
ON

When the relay is off, the COM (common)
pin will be connected to the NC (Normally

A Closed) pin. When the relay is on, the COM
(common) pin will be connected to the NO
(Normally Open) pin.

L—@ +5volts

GND ——
(ground) () ~—

Relay Transistor o, Diode 330Q LED Wire
P2N2222AG y 1N4148 Resistor /
2 /2 x4




Circuit 13: Relays
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Code to Note:

=

digitalWrite(relayPin, HIGH);

digitalWrite(relayPin, LOW);

What You Should See:

You should be able to hear the
relay contacts click, and see the
two LEDs alternate illuminating
at 1-second intervals. If you
don't, double-check that you
have assembled the circuit
correctly, and uploaded the
correct sketch to the board. Also,
see the troubleshooting tips below.

Troubleshooting:

LED:s Not Lighting

Double-check that you've plugged them in correctly. The
longer lead (and non-flat edge of the plastic flange) is the
positive lead.

No Clicking Sound
'The transistor or coil portion of the circuit isn't quite
working. Check the transistor is plugged in the right way.

Not Quite Working

'The included relays are designed to be soldered rather than
used in a breadboard. As such you may need to press it in
to ensure it works (and it may pop out occasionally).

00

When we turn on the transistor, which in turn energizes

the relay's coil, the relay's switch contacts are closed. This
connects the relay's COM pin to the NO (Normally Open)
pin. Whatever you've connected using these pins will turn

on. (Here we're using LEDs, but this could be almost anything.)

The relay has an additional contact called NC (Normally
Closed). The NC pin is connected to the COM pin when
the relay is OFF. You can use either pin depending on
whether something should be normally on or normally off.
You can also use both pins to alternate power to two

devices, much like railroad crossing warning lights.

Real World Application:

Garage door openers use relays to operate. You might be
able to hear the clicking if you listen closely.

| s S T




CIRCUIT #14

_— Shift Register

+5 volts
resistors (3300hm) | Epg I Now we are going to step into the world of ICs (integrated
(Orange-Orange-Brown) L. L. N . .
M —Kt 15 16 10 [ | circuits). In this circuit, you'll learn all about using a shift
cock | [mt ] register (also called a serial-to-parallel controller). The shift
——WW—Kt ron T i ill gi Arduin dditional eight outputs
register will give your Arduino an a tputs,
L W—kt 2 12 fateh [_pin2 | using only three pins on your board. For this circuit, you'll
s 1 data practice by using the shift register to control eight LEDs.
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Code to Note: v o °

:> You'll communicate with the shift register (and a lot of other parts)

using an interface called SPI, or Serial Peripheral Interface. This

. . . . . interface uses a data line and a separate clock line that work together

shiftOut(datapin, clockpin, MSBFIRST, data); ! s
to move data in or out of the Arduino at high speed. The MSBFIRST
parameter specifies the order in which to send the individual bits, in

this case we're sending the Most Significant Bit first.

:> Bits are the smallest possible piece of memory in a computer; each
one can store either a "1" or a "0". Larger numbers are stored as arrays
I . R R of bits. Sometimes we want to manipulate these bits directly, for
bitWrite(data,desiredPin,desiredState); . L . I
example now when we're sending eight bits to the shift register and

we want to make them 1 or 0 to turn the LEDs on or off. The Arduino

has several commands, such as bitWrite(), that make this easy to do.

What You Should See:

You should see the LEDs light up
similarly to in circuit 4 (but this
time, you're using a shift register).
If they aren't, make sure you have
assembled the circuit correctly
and verified and uploaded the
code to your board, or see the
troubleshooting tips below.

Troubleshooting: Real World Application:

The Arduino's power LED goes out Similar to circuit #4, a scrolling marquee display delivers
This happened to us a couple of times, it happens when a mesage with multiple LEDs. Essentially the same task
the chip is inserted backward. If you fix it quickly the shift register achieves here in Circuit #14.

nothing will break.

Not Quite Working

Sorry to sound like a broken record but it is probably
something as simple as a crossed wire.

e .

o

e o
Frustration 2 80 eee e e e 8 e

Shoot us an e-mail, this circuit is both simple and
complex at the same time. We want to hear about
problems you have so we can address them in future

editions: techsupport@sparkfun.com



Visit us Online:

This is just the beginning of your exploration into
embedded electronics and coding. Our website has a
wealth of tutorials to whet your appetite for more
knowledge. We also host a community of hackers,
engineers, DIYers, etc. in our forums. So log on to our
website for more information about Arduino, or to plan
ahead for your next project!

¢ ) sparkfun.com




@00

BY SA

This work is licensed under the Creative Commons Attribution-Share Alike 3.0 Unported License.

To view a copy of this license visit:
http://creativecommons.org/licenses/by-sa/3.0/

Or send a letter to:
Creative Commons, 171 Second Street, Suite 300, San Francisco, California 94105, USA.




